最近发表的话题
最近发表的评论
  • 地区三级联动,新手容易只出现 {{name}} 的一个隐蔽原因 at 3小时前

    兄弟我和你一样,但是我找到解决办法了,这里可以分享一下,我看了一下 github 上的源码,发现有行代码不一样
    github.com/summerblue/laravel-shop...
    我们默认的是

    window.Vue = require('vue');

    改成,多了一个 .default

    window.Vue = require('vue').default;

    我的 app.js 如下

    require('./bootstrap');
    window.Vue = require('vue').default;
    require('./components/SelectDistrict');
    const app = new Vue({
        el: '#app',
    });

    解释如下

    1. 也不需要把 SelectDistrict.js 改为 SelectDistrict.vue
    2. 使用 require 是 CommonJS 的模块导入方式,不支持模块的默认导出,因此导入的结果其实是一个含 default 属性的对象,因此需要使用 .default 来获取实际的组件选项。
  • L05 Laravel5.7 电商实战 新增收货地址 不显示数据 {{ name }} at 3小时前

    解释如下
    1.使用 require 是 CommonJS的模块导入方式,不支持模块的默认导出,因此导入的结果其实是一个含 default 属性的对象,因此需要使用 .default 来获取实际的组件选项。

  • L05 Laravel5.7 电商实战 新增收货地址 不显示数据 {{ name }} at 3小时前

    兄弟我和你一样,但是我找到解决办法了,这里可以分享一下,我看了一下 github 上的源码,发现有行代码不一样 我们默认的是

    window.Vue = require('vue');

    改成, 多了一个 .default

    window.Vue = require('vue').default;

    我的 app.js 如下

    require('./bootstrap');
    window.Vue = require('vue').default;
    require('./components/SelectDistrict');
    const app = new Vue({
        el: '#app',
    });
  • 地区三级联动,新手容易只出现 {{name}} 的一个隐蔽原因 at 3小时前

    @bing_ 我没注释 console之前是 Uncaught TypeError: Vue is not a constructor,注释后不报错了,但依旧是 {{ name }}

  • homestead.test访问不了,显示500错误 at 1周前

    我也是这样子,可以 ping 通 域名,但是浏览器就是 无法访问

  • 按照《开发环境搭建 - Windows》搭建的开发环境,但是 homestead.test 无法访问 at 1周前

    请问一下我是可以 ping 通域名,但是无法访问 file host 以及 yarm 如下

    file

    file vagrant up --provision 之后 访问浏览器访问 shop.test 失败

    file

    接着继续访问 ip 看下 192.168.10.10

    file 那就说明是 homestead 虚拟机的原因了 然后看了下 code 目录是否映射到虚拟机去了,发现在

    file 然后看了下 nginx.conf 反正我是没辙了

    vagrant@homestead:/etc/nginx$ cat nginx.conf
    user vagrant;
    worker_processes auto;
    pid /run/nginx.pid;
    include /etc/nginx/modules-enabled/*.conf;
    
    events {
            worker_connections 768;
            # multi_accept on;
    }
    
    http {
    
            ##
            # Basic Settings
            ##
    
            sendfile on;
            tcp_nopush on;
            tcp_nodelay on;
            keepalive_timeout 65;
            types_hash_max_size 2048;
            # server_tokens off;
    
            server_names_hash_bucket_size 64;
            # server_name_in_redirect off;
    
            include /etc/nginx/mime.types;
            default_type application/octet-stream;
    
            ##
            # SSL Settings
            ##
    
            ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # Dropping SSLv3, ref: POODLE
            ssl_prefer_server_ciphers on;
    
            ##
            # Logging Settings
            ##
    
            access_log /var/log/nginx/access.log;
            error_log /var/log/nginx/error.log;
    
            ##
            # Gzip Settings
            ##
    
            gzip on;
    
            # gzip_vary on;
            # gzip_proxied any;
            # gzip_comp_level 6;
            # gzip_buffers 16 8k;
            # gzip_http_version 1.1;
            # gzip_types text/plain text/css application/json application/javascript text/xml application/xml application/xml+rss text/javascript;
    
            ##
            # Virtual Host Configs
            ##
    
            include /etc/nginx/conf.d/*.conf;
            include /etc/nginx/sites-enabled/*;
    }
    
    

    然后接着看了几个引入的文件 include /etc/nginx/modules-enabled/*.conf, include /etc/nginx/conf.d/*.conf, include /etc/nginx/sites-enabled/*

    1. 看着不像我找到的 file

    2. 是空的 file

    3. 找到相关配置 了,但是我不知道那里有问题,贴一下给大家看下

      vagrant@homestead:/etc/nginx$ cat sites-enabled/shop.test
      conf.d/            koi-utf            modules-available/ proxy_params       sites-enabled/     win-utf
      fastcgi.conf       koi-win            modules-enabled/   scgi_params        snippets/
      fastcgi_params     mime.types         nginx.conf         sites-available/   uwsgi_params
      vagrant@homestead:/etc/nginx$ cat sites-enabled/shop.test
      server {
       listen 80;
       listen 443 ssl http2;
       server_name .shop.test;
       root "/home/vagrant/code/laravel-shop/public";
      
       index index.html index.htm index.php;
      
       charset utf-8;
       location / {
           try_files $uri $uri/ /index.php?$query_string;
      
       }
      
      
      
    location = /favicon.ico { access_log off; log_not_found off; }
    location = /robots.txt  { access_log off; log_not_found off; }
    
    access_log off;
    error_log  /var/log/nginx/shop.test-error.log error;
    
    sendfile off;
    
    location ~ \.php$ {
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass unix:/var/run/php/php8.0-fpm.sock;
        fastcgi_index index.php;
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    
    
        fastcgi_intercept_errors off;
        fastcgi_buffer_size 16k;
        fastcgi_buffers 4 16k;
        fastcgi_connect_timeout 300;
        fastcgi_send_timeout 300;
        fastcgi_read_timeout 300;
    }
    
    location ~ /\.ht {
        deny all;
    }
    
    ssl_certificate     /etc/ssl/certs/shop.test.crt;
    ssl_certificate_key /etc/ssl/certs/shop.test.key;

    } ```

  • 增加图标后报错 ["tabBar"]["list"][0] 未找到 at 4个月前

    被这小细节折磨死了

  • [已解决] 编辑接口请求的用户表是 user,不是 users。 at 4个月前

    谢谢,这个对我有帮助,我是报找不到image,看了你的回答, UserRequest.php 里面校验的时候表面少些了一个【s】

  • 按照教程做到这里,返回的结果与教程不一样,是什么原因呢?详见正文图片 at 4个月前
    谢谢,我已经知道了,后面还需要在body中传参code或者access_token+openid参数
  • 按照教程做到这里,返回的结果与教程不一样,是什么原因呢?详见正文图片 at 4个月前
    请问除了传参social_type之外,还需要传哪个参数?
  • 用户注册提交后,为什么保存的 password 没有加密 at 4个月前
    @Ricc setPasswordAttribute方法 在App\Models\User.php中
  • 执行 PHP artisan migrate 数据库迁移时报这个错误,已解决 at 4个月前

    谢了,已解决

  • $link->cache_key 用法是不是有错误 at 5个月前

    终于找到问题所在了,就是 这个属性

  • 安装防御xss插件没有生效的问题 at 5个月前

    在App\Providers\AppServiceProvider.php 中的boot方法里添加楼主的代码就ok 了

  • 修改 webpack.mix.js 不生效 at 9个月前

    回答很有价值

  • Laravel 7.11 发布 at 1年前

    我还在用 5.5 :joy::joy:

  • 程序员的键盘使用指南 at 1年前
    cmd + c 和 v 太多了吧 😝
  • 节流限制问题 at 1年前
    @logic 默认值
  • @_Fairy 在 2019-12-13 11:39:34 的动弹 at 1年前

    看项目大小吧,如果很小,直接 blade 也不错

  • 阿里云数据库 rds 链接不上问题 at 1年前
    @Jouzeyu 读取到了呀,那你可以直接把参数写在 config 里试试,不从 .env 文件读,这样就确定了是不是读取 env 文件有问题