为什么 yarn add cross-env 就是报错,有通用解决方案吗

教程 is_echo ⋅ 于 3个月前 ⋅ 最后回复由 VKWF_ 2个月前 ⋅ 230 阅读

执行命令:yarn add cross-env后如下

warning fsevents@1.1.3: The platform "linux" is incompatible with this module.
info "fsevents@1.1.3" is an optional dependency and failed compatibility check. Excluding it from installation.
[3/4] Linking dependencies...

█████████████████████████████████
███████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████████░
░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░░
error An unexpected error occurred: "EPROTO: protocol error, symlink '../acorn/bin/acorn' ->
'/home/vagrant/Code/sample/node_modules/acorn-dynamic-import/node_modules/.bin/acorn'".

info If you think this is a bug, please open a bug report with the information provided in "/home/vagrant/Code/sample/yarn-
error.log".
info Visit https://yarnpkg.com/en/docs/cli/add for documentation about this command.
vagrant@homestead:~/Code/sample$

完全按教程来操作每个步骤,为啥在这被卡了几天了。偿试了别人的把package.json“cross-env”字符删掉,还是报同样的错误。各位大哥,麻烦指导一下,,
https://laravel-china.org/courses/laravel-essential-training-5.5/569/style-beautification

本文章首发在 Laravel China 社区
成为第一个点赞的人吧 :bowtie:
回复数量: 3
  • young Code is Poetry 1
    3个月前

    homestead 或者 Windows环境下可以尝试在yarn 命令后面加 --no-bin-links

  • Summer MOD A Life-long learner. 1
    3个月前

    在虚拟机下,尝试运行下面这个命令

    npm install acorn --no-bin-links

  • VKWF_
    2个月前

    @Summer 查了N个答案,总算解决了 :+1:

暂无评论~~
您需要登陆以后才能留下评论!

Composer 中国全量镜像

Top 100 扩展包

Lumen 中文文档

Laravel 速查表

Laravel 中文文档

Laravel 项目开发规范

Laravel 开发环境部署

Elasticsearch-PHP 中文文档

Lumen 中文文档

GraphQL PHP 中文文档

社区文档撰写指南

TDD 构建 Laravel 论坛笔记

PHP PSR 标准规范

PHP 设计模式全集

Dingo API 中文文档