【升级公告】PHPHub 现在运行在 Laravel 5.1 上
15

说明

升级顺利完成! :beers: :beers: :beers:

开发时间比较着急,估计会有一些 Bug,欢迎大家反馈哈。

附上新项目地址:https://github.com/summerblue/phphub5

新功能

已知 BUG:


Practice makes perfect.

本帖已被设为精华帖!
本帖由 Summer 于 2年前 取消置顶
《L01 基础入门》
我们将带你从零开发一个项目并部署到线上,本课程教授 Web 开发中专业、实用的技能,如 Git 工作流、Laravel Mix 前端工作流等。
《L03 构架 API 服务器》
你将学到如 RESTFul 设计风格、PostMan 的使用、OAuth 流程,JWT 概念及使用 和 API 开发相关的进阶知识。
讨论数量: 64

变样了。。

2年前

现在是单页面应用了么? 猜用了 React + Redux ,厉害厉害!!!

2年前

赞,等了好久拉

2年前

登录变得如此犀利... 都不用跳转了,直接就上去~~

2年前

file

是从coding上取代码吗?

2年前

@wingofsky 多谢指出,已经修正

2年前

广告图跑出去了

file

2年前

拼写错误

file

2年前
Summer

@dinghua 两个都搞定了 :rose:

2年前

登录图片错位?

file

2年前
Summer

@madman121 这个应该是 GitHub 的问题,还真改不了 :flushed:

2年前

哈哈,又有可以学习的项目了,感谢!!!

2年前

感觉好漂亮呀,嘿嘿。

2年前

file

这里感觉好挤呀,你们觉得呢?

2年前
wujunze

升级后 感觉很赞

2年前

@lijinma 这块样式我们正在处理哦,感谢指出 :rose::rose:

2年前
Summer

@lijinma 刚刚被我该坏掉了。

2年前

@Summer 现在好了。Summer

2年前

普天同庆...

2年前

IOS 客户端,数据刷新不出来。

2年前
Summer

@jiemoon 收到,紧急修复中

2年前

file GitHub 帐号更改后更新缓存还是有bug @Summer

2年前

@waltjiang 应该是你的 GitHub name 数据不对

为此我加了一个功能,可参考下图,先去修改一下 GitHub name,再点击「更新缓存」应该就 OK 了 :smile:

file

2年前

提个意见,新版比原来漂亮,但是好像过宽了,看上去有些累(比如将视线从左移到右边时)。

2年前
Summer

@Payne 主要是考虑到大部分用户是宽屏。

2年前
lifesign

:rose: :rocket:

2年前

希望给程序添加一个注册用户功能,用户关联github功能,ios希望能更新下,目前apple store的上架政策不允许仅仅靠第三方登陆或者纯扫码登陆,所以还是请整个登陆页面吧。ios好久没更新了,有时间更新下喲!

2年前
Summer

@bbs7txt 多谢建议哈,有计划在开放注册,之前是考虑用户纯净点

2年前

@Summer 期待

2年前

怎么安装扩展包依赖时下载失败,是不是还没有中国镜像

2年前

喜欢这个样式 小清新

2年前

:+1: 学习一下

2年前

composer install 提示错误,搞了半个小时没有改好,有没有人遇到过?
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Warning: The lock file is not up to date with the latest changes in composer.json. You may be getting outdated dependencies. Run update to update them.
Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for smartisan/follow 1.0.0 -> satisfiable by smartisan/follow[1.0.0].
  • smartisan/follow 1.0.0 requires laravel/laravel >= 5.1 -> no matching package found.

Potential causes:

Read https://getcomposer.org/doc/articles/troubleshooting.md for further common problems.

2年前

已解决! 通过 git clone 下载下来的没有问题,直接下载压缩包的有问题!

2年前

[root@phphub phphub5]# composer install
Do not run Composer as root/super user! See https://getcomposer.org/root for details
Loading composer repositories with package information
Installing dependencies (including require-dev) from lock file
Nothing to install or update
Generating autoload files

Illuminate\Foundation\ComposerScripts::postInstall
php artisan optimize
PHP Fatal error: Class 'Illuminate\Routing\ControllerServiceProvider' not found in /usr/local/nginx/html/phphub5/vendor/laravel/framework/src/Illuminate/Foundation/ProviderRepository.php on line 146

[Symfony\Component\Debug\Exception\FatalErrorException]
Class 'Illuminate\Routing\ControllerServiceProvider' not found
这个问题是什么问题呢?

2年前
Summer

@木头人 没有遇到过,是照着文档来着吗?

2年前

@Summer 可能是我做的过程哪里出了问题。稍后我会重新做一次的。谢谢大神
我想问一下,您那里有android端的源码吗?我在github上下载的源码我们工程师说缺少什么东西无法编译。
或者您的编译环境是什么呢?

2年前

已解决 使用git clone 下载下来的包没有问题,下载的zip包可能有问题。但是现在格式是乱的

file

http://ip/admin没有页面

2年前

消息通知页面

file

2年前
Summer

@dinghua fixed

2年前

好漂亮~

2年前

@wzhystar 执行 php artisan db:seed 后后台可以直接访问!感谢

2年前

站长啊~用phphub做二次开发,然后用于非商业模式,非营利组织不碍事吧?

2年前
Summer

@asdasdaasdas 随便用,有心的话在页脚或者哪里加个链接链过来 PHPHub 网站即可。

2年前

@Summer 必须哒!

2年前

@Summer 对咯站长,你现在服务器配置是多大的?参考下我

2年前

@Summer

Phphub 的MailDriver是使用 sendcloud,

如果要把它修改為一般的mail server是不是還缺了email template ???

2年前

Your requirements could not be resolved to an installable set of packages.

Problem 1

  • Installation request for intervention/image 2.3.7 -> satisfiable by intervention/image[2.3.7].
  • intervention/image 2.3.7 requires ext-fileinfo * -> the requested PHP extension fileinfo is missing from your system.
    Problem 2
  • Installation request for smartisan/follow 1.0.0 -> satisfiable by smartisan/follow[1.0.0].
  • smartisan/follow 1.0.0 requires laravel/laravel >= 5.1 -> no matching package found.

Potential causes:

Read https://getcomposer.org/doc/articles/troubleshooting.md for further common problems.
To enable extensions, verify that they are enabled in those .ini files:

  • /usr/local/php/etc/php.ini
    You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

这是什么问题啊

2年前

支持

2年前

未登录状态下打开帖子页面(比如本页面),谷歌浏览器会报个 js 错误:

main.js:142 Uncaught TypeError: at_users.push is not a function

应该完全没影响,但是不得其解

2年前

@qqjt 已经修复了,感谢指出。

2年前

package.json 应该是少了 social-share.js 这个包?

2年前

如果我想自定义登录方式这是否可行,比如我只想要steam登录

2年前

@Summer IOS的什么时候好?都16天过去了,不是说好的一到两个星期么?

2年前
Summer

@Fackeronline :grimacing: 看来是重度用户哈,社区功能现在还变化很大,想等功能再沉淀沉淀以后再优化 API 部分

2年前

@Summer 那大概要多久才能恢复IOS端的正常使用?

2年前
Summer

@forehalo 你说的问题搞定了,多谢哈

2年前

标题和页面内容不一致

file

2年前

使用Laravel是否会遇到性能问题,是怎么优化的呢

2年前

@木头人 我的也是可以访问了,就是前台页面样式乱的,按照文档中npm install【时间真长,不知道是在解析什么东西】,然后gulp后,页面还是乱。不知道你解决了没有

2年前

@我是真理
前台 我 i 也很乱.... 不登陆ok ,登陆管理员后一片乱

1年前

何时支持 多种登陆方式啊,国内微信登陆不现实。。。需要交费300一年验证

1年前

@Summer 最近有没有计划升级到Laravel 5.5版本?

11个月前

  • 请注意单词拼写,以及中英文排版,参考此页
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`, 更多语法请见这里 Markdown 语法
  • 支持表情,使用方法请见 Emoji 自动补全来咯,可用的 Emoji 请见 :metal: :point_right: Emoji 列表 :star: :sparkles:
  • 上传图片, 支持拖拽和剪切板黏贴上传, 格式限制 - jpg, png, gif
  • 发布框支持本地存储功能,会在内容变更时保存,「提交」按钮点击时清空
  请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!