结合 Laravel 5.5 + vue 2.5 开发的博客

分享 xuecong ⋅ 于 3个月前 ⋅ 最后回复由 sunlinesun 4天前 ⋅ 2429 阅读

此博客是基于laravel 5.5vue 2.5开发。后台用的是element-ui。

  1. 网站:https://overxue.com
  2. 源码:https://github.com/overxue/blog

前段时间在github上看到了美团开源的小程序框架mpvue,正好拿这个博客试了下水,用起来还是蛮爽的。

  1. 源码:https://github.com/overxue/mpblog

    扫码体验

    file

欢迎各位 issues、stars,我会不断完善这个博客,大家互相学习。

本文章首发在 Laravel China 社区
本帖已被设为精华帖!
本帖由系统于 3个月前 自动加精
回复数量: 21
  • 多谢分享,学习了。
    不过有时候个人项目,并不是很推荐前后端分离。
    感觉怎么轻松怎么来。
    抱着学习的态度,这个真的真的很赞。

    3个月前
  • liyu001989 教程作者 @ 自由职业

    @NeilyoSummer 反对,个人项目才是学习练手的好时机,新工具新技术这个时候不用什么时候用。

    怎么轻松怎么来,搭个 wordpress 不就得了。

    给楼主点个赞

    3个月前
  • @liyu001989 可能有偏薄,我更正下个人项目分学习和要上线的项目,要时间紧急是没必要给自己添堵,怎么舒服怎么来。
    如果是为了练手,那么随意反正时间不紧张可以慢慢跳坑然后慢慢出坑哈哈哈

    3个月前
  • 点赞,刚开始用mpvue做项目,也打算抽个时间出来写个博客,希望能够越来越丰富

    3个月前
  • @科大大 谢谢。最近公司项目比较忙,所以就没怎么弄了。有时间肯定会完善它的。

    3个月前
  • 很赞,终于能找到一个好项目能学习下了 ,还望楼主能持续更新

    3个月前
  • 楼主,我下载了两次在不同的地方,一次成功 另外一次到编译前端文件哪一步出问题了 编译不了

    2个月前
  • @Code_Er 是blog这个吗?

    2个月前
  • @xuecong 对的 yarn install 后 npm run dev 编译不了

    2个月前
  • @Code_Er yarn install会不会报错?

    2个月前
  • @xuecongyarn npm install 印象中是好像有一个

    2个月前
  • @Code_Er 如果用的是windows安装的homestead的话,在虚拟机里面执行yarn install 改为 yarn install --no-bin-links

    2个月前
  • 好的 楼主但是有一个问题 我在公司电脑同样也是windows 安装homestead 但是这次就能成

    2个月前
  • @Code_Er 这个我就无从下手了。只要能跑起来,说明程序上没有错误的。

    2个月前
  • @xuecong 楼主可以请教下laravel 环境下 yarn install 跟 npm install是冲突的吗?

    2个月前
  • @Code_Er 不冲突。

    2个月前
  • @xuecong 好的感谢

    2个月前
  • @xuecong mpvue如何生成web项目?文档没写,只有生成小程序的

    2个月前
  • @xiao345 mpvue和vue有好多地方不兼容,我是把vue的css和html拿过来的。

    2个月前
  • @xuecong 好的

    2个月前
  • 谢谢楼主的分享,赞一个

    2周前
您需要登陆以后才能留下评论!

Composer 中国全量镜像

Top 250 扩展包

Lumen 中文文档

Laravel 速查表

Laravel 中文文档

Laravel 项目开发规范

Laravel 开发环境部署

Composer 中文文档

Elasticsearch-PHP 中文文档

Lumen 中文文档

GraphQL PHP 中文文档

社区文档撰写指南

TDD 构建 Laravel 论坛笔记

PHP PSR 标准规范

PHP 设计模式全集

Dingo API 中文文档