Menu

安装

安装

安装

运行环境要求

Lumen 框架会有一些系统上的要求。 当然这些要求在 Laravel Homestead 虚拟机上都已经完全配置好了。因此强烈建议您将 Homestead 用作你本地的 Lumen 开发环境。

如果你没有安装 Homestead 的话,请确保你的系统环境符合要求:

  • PHP >= 7.1.3
  • OpenSSL PHP Extension
  • PDO PHP Extension
  • Mbstring PHP Extension

安装 Lumen

Lumen 利用 Composer 来管理它的代码依赖. 所以,在使用 Lumen 之前,请先确认你的电脑上安装了 Composer。

通过 Lumen 安装器

首先,使用 Composer 下载 Lumen 安装包:

composer global require "laravel/lumen-installer"

请确定你已将 ~/.composer/vendor/bin 路径加到环境变量中的 PATH ,只有这样系统才能找到 lumen 的可执行文件。

一旦安装完成,使用 lumen new 将会在您指定的目录中创建一个新的
Lumen 项目。例如: lumen new blog 命令将会创建一个名字叫 blog 的目录 ,此目录里面存放着新安装的 Lumen 和代码依赖。这个方法的安装速度比通过 Composer 安装要快很多:

lumen new blog

通过 Composer Create-Project 命令安装

你也可以在你电脑的终端输入 create-project 命令来安装 Lumen :

composer create-project --prefer-dist laravel/lumen blog

运行你的应用程序

在你的本地运行项目,你可以使用 Laravel Homestead 虚拟机,Laravel Valet ,或者内置的 PHP 开发服务器:

php -S localhost:8000 -t public

配置

Lumen 框架所有的配置信息都是存在 .env 文件中。一旦 Lumen 成功安装,你同时也要配置本地环境.

应用程序密钥

在你安装完 Lumen 后,首先需要做的事情是设置一个随机字符串到应用程序密钥。通常这个密钥会有 32 字符长。 这个密钥可以被设置在 .env 配置文件中。如果你还没将 .env.example 文件重命名为 .env,那么你现在应该去设置下。如果应用程序密钥没有被设置的话,你的用户 Session 和其它的加密数据都是不安全的!

本文章首发在 Laravel China 社区
上一篇 下一篇
讨论数量: 0
发起讨论


暂无话题~
刻意练习,每日精进。
0
点赞
426
浏览
0
讨论
译者