Menu

2.1. 安装

系统要求

为了安装这个包你需要:

  • PHP ^7.0

你必须在你的项目中修改 composer.json 文件并且运行 composer update 命令来加载这个包的最新版本。

"require": {
    "dingo/api": "2.0.0-alpha1"
}

现在,这个包仍然处于开发阶段,因此没有一个 稳定 的发布版。
你可能需要设置 minimum-stability 的值为 dev

一旦这个包被安装,下一步取决于你使用那个框架。

Laravel

使用以下命令可以发布 API 的配置文件到 config 文件下:

php artisan vendor:publish --provider="Dingo\Api\Provider\LaravelServiceProvider"

Lumen

如果你使用 Lumen,请打开 bootstrap/app.php 并注册服务提供者:

$app->register(Dingo\Api\Provider\LumenServiceProvider::class);

Facades

API 自带了两个 Facade,你可以酌情使用。

Dingo\Api\Facade\API

这个是调度器的 Facade ,并提供了一些好用的辅助方法。

Dingo\Api\Facade\Route

你可以使用这个 Facade 来获取 API 的当前路由、请求、检查当前路由的名称等。

本文章首发在 Laravel China 社区
上一篇 下一篇
讨论数量: 0
发起讨论


暂无话题~