Menu

4.6. 为什么限制版本是最佳实践?

为什么未绑定版本限制是一个坏主意?

没有上界的版本约束,如 *,>=3.4 或者 dev-master,将允许更新依赖项的任何未来版本。这包括当前向后兼容性的主要版本。

一旦你的包的发布被标记,你就不能调整它的依赖性,以防依赖性破坏 BC- 你必须做一个新的发布,但是前一个版本会被打破。

唯一好的选择是定义约束的上限,在测试了包与依赖的新主版本兼容后,可以在新版本中增加。

例如,而不是使用 >=3.4 你应该使用 ~3.4 允许所有版本达到 3.999 但不包括4.0及以上。^ 操作符与 语义版本 控制 的库一起工作得很好。

注意:作为一个包维护程序,您可以通过为开发分支提供 别名版本 来允许用户与绑定约束匹配,从而使用户的使用更容易。

本文章首发在 Laravel China 社区
上一篇 下一篇
讨论数量: 0
发起讨论


暂无话题~