Homestead 下切换 PHP 版本
20

前言

Laravel 的Homestead中自带了 PHP5.6、PHP7.0、PHP7.1、PHP7.24个版本。默认运行的最好版本7.2,但有时公司需求不得不切换到别的版本。怎么切换呢?Homestead中自带了切换版本的方式,如下:

sites:
    - map: homestead.test
      to: /home/vagrant/code/Laravel/public
      php: "5.6"

但是,当你在homestead中执行composer 时,或者用 php -v 查看php版本时,还是7.2的。导致composer 进行版本检查时或者更新包时,都是按照7.2版本来更新的。怎么办呢,homestead中自带了版本管理工具
update-alternatives

用法如下:

update-alternatives --display php 查看所有php版本和当前版本
update-alternatives --config php 执行后,会列出当前php所有版本和编号,输入编号,切换到执行的版本
本帖由系统于 6天前 自动加精
《L03 构架 API 服务器》
你将学到如 RESTFul 设计风格、PostMan 的使用、OAuth 流程,JWT 概念及使用 和 API 开发相关的进阶知识。
《L05 电商实战》
从零开发一个电商项目,功能包括电商后台、商品 & SKU 管理、购物车、订单管理、支付宝支付、微信支付、订单退款流程、优惠券等
讨论数量: 5

vagrant update-alternatives --display php
是这么用的吗

1个月前

@xingchen 不是,vagrant ssh 后执行

1个月前

@xmkl 在vagrant ssh 后执行,直接报没有这个命令。。-bash: vagrant: command not found

1个月前

@王成涛 这个好像只是在cli 里面切换版本,打印PHPinfo 还是以前的。。

1个月前

  • 请注意单词拼写,以及中英文排版,参考此页
  • 支持 Markdown 格式, **粗体**、~~删除线~~、`单行代码`, 更多语法请见这里 Markdown 语法
  • 支持表情,使用方法请见 Emoji 自动补全来咯,可用的 Emoji 请见 :metal: :point_right: Emoji 列表 :star: :sparkles:
  • 上传图片, 支持拖拽和剪切板黏贴上传, 格式限制 - jpg, png, gif
  • 发布框支持本地存储功能,会在内容变更时保存,「提交」按钮点击时清空
  请勿发布不友善或者负能量的内容。与人为善,比聪明更重要!